Author Topic: d3dx10_34.dll was not found  (Read 1708 times)

0 Members and 1 Guest are viewing this topic.

Offline Hwkbrt3531

  • Bondsman
  • *
  • Posts: 2
  • l33tp0intz: +0/-0
d3dx10_34.dll was not found
« on: January 02, 2014, 10:07:25 PM »
Hi everyone,

I am trying to install MWLL through the full installer offered on the front page. I am able to download it and then install it successfully, but when I open up the launcher and try to start the game I get the following error message:

"This application has failed to start because d3dx10_34.dll was not found. Re-installing the application may fix this problem."

I have tried uninstalling and then reinstalling multiple times as well downloading the file from different sources to rule out the possibility of a corrupt download. Besides that, I don't know what else to do. I am running Vista 64 bit. Any responses are appreciated.

Thanks everyone!

Offline b0bgeld0f

  • Recruit
  • *
  • Posts: 157
  • l33tp0intz: +33/-2
Re: d3dx10_34.dll was not found
« Reply #1 on: January 03, 2014, 01:56:23 AM »
hey man, glad your here but sorry to hear of your troubles... Im far from an expert in this area, but one thing i can suggest is:

There is an option in the launcher to "force direct X9 mode"
try ticking that box and running it again.. If that doesnt fix it for you try working through this:

(change the xx to tt, im still not sure of the link rules here)

if that doesnt work, then hopefully someone with more knowledge will be along to help you further, there are some good eggs here :)

Offline Perigren

  • Alphatester
  • Lance Sergeant
  • *
  • Posts: 378
  • l33tp0intz: +10/-0
  • Eh?
Re: d3dx10_34.dll was not found
« Reply #2 on: January 03, 2014, 02:35:07 AM »
I had the same issue, go to ms downloads and install directx for your specific os, it cured my problem.
AMD Phenom II x6 1090T BE @ 3.2 Ghz,ZALMAN CNPS9900MAX-B 135mm Long life bearing CPU Cooler
ASUS M4A89TD PRO/USB3 AM3 AMD 890FX SATA 6Gb/s USB 3.0 ATX AMD Motherboard
CORSAIR XMS3 8GB (4 x 2GB)  DDR3 1333
MSI R6950 Twin Frozr III PE/OC Radeon HD 6950 2GB 256-bit GDDR5, 2x 21.5" Samsung LED monitors(BX-2231)
Kingston 96 Gb SSD, Western Digital Caviar Black 500GB 7200 RPM SATA III
Win 7 Ultimate 64 bit

Offline Bruno_007

  • Apprentice Dev
  • Star Captain
  • *
  • Posts: 833
  • l33tp0intz: +90/-0
  • Osiris hats: sold out. ~Str1k3r
Re: d3dx10_34.dll was not found
« Reply #3 on: January 03, 2014, 09:44:30 AM »

What games include is the DirectX redistributable version, which is available as a download anyway from microsoft, so installing a game shouldn't be needed.

Anyway, this answers all questions:

List of file failures that the DirectX End-User Runtime package fixes

If you experience issues in which an application fails because any of the following files are missing, you may be able to resolve the failure by running the DirectX run-time package:
  • (...)
  • D3DX10.DLL through D3DX10_43.DLL
  • (...)

But haven't he made that yet, running the DirectX run-time installer?
Tools and I:
   - MWLL Online Launcher (LAN UDP Forwarder) - evolution of past "Le Proof of Concepto" project: connect without Gamespy via packet redirection;
   - Vehicle Browser - "Pocket Wiki" ©okaolias (not really that though);
   - Rconnect 4.3 - Server tools: map manager/player voting add-ons;
   - CryHammer - Validates Patch/CDKey of Crysis Wars (now unable to validate CDKey due to turned off Gamespy servers).

Offline Hwkbrt3531

  • Bondsman
  • *
  • Posts: 2
  • l33tp0intz: +0/-0
Re: d3dx10_34.dll was not found
« Reply #4 on: January 04, 2014, 12:10:33 AM »
Thanks guys, installing the DirectX End-User Runtime package was what fixed it. See you all on the battlefield!