Public Discussion > Tech Forum

Need to revert TeamSpeak versions?

(1/2) > >>

CHHš Siege:
Just launched TeamSpeak and made the mistake of letting it update itself? Can't connect to any servers?

Fix it by reverting to an older version here.

CHHš Siege:
As of this posting, the most recent version is beta 36, which will not work with any server prior to it; If you're having a problem, uninstall your current version and install beta-35 from the above link.

Aidan:
Thanks Siege! That is one handy link.  :)

GB-72AT Talon:
mine updated to 3.0.0-rc2 yesterday and worked fine on Outreach

Draekros:

--- Quote from: GB-72AT Talon on June 11, 2011, 01:16:03 AM ---mine updated to 3.0.0-rc2 yesterday and worked fine on Outreach

--- End quote ---

Same - no probs from my end either, I was chatting and dying as usual last night.  :P

Navigation

[0] Message Index

[#] Next page

Go to full version